A security patch for v1.3.0 and earlier. It raises the minimum handlebars version to
4.7.10 to close critical vulnerabilities, so you only need to update your docouture
packages.
Do this
-
Update every
@inditextech/docouture-*package, and the CLI if you install it, to1.3.1. In a scaffolded site these are pinned indocs/package.json. -
Run
docouture upgradeif you use the CLI, then run your package manager’sinstall(for examplepnpm install) to refresh the lockfile. -
Check that your lockfile no longer contains
handlebars@4.7.9.
No workflow, playbook or content changes are needed. If you are coming from before v1.3.0, also follow the checklist in v1.3.0.
Why this matters
Antora’s @antora/page-composer accepts any handlebars ~4.7, so a site that installed
earlier keeps the vulnerable 4.7.9 through its existing lockfile, even though a fixed
release exists. v1.3.0 and earlier do not stop that.
-
Fix.
@inditextech/docouture-antora-extensionsnow depends onhandlebars~4.7.10. The package manager has to resolve one version that satisfies both ranges, so a fresh install, or an update of the docouture packages, moves to4.7.10or later. -
Alerts closed. Three advisories, GHSA-xw65-4hp5-5hc7 (medium), GHSA-8r5x-fm3f-whwj (critical) and GHSA-p8wg-vrv2-v86f (critical), all affecting
handlebarsup to 4.7.9. -
Development tooling. The UI bundle’s build-time
handlebarsis bumped to~4.7.10, and the repository’s own development dependenciesvite(7.3.7) andfollow-redirects(1.16.1) are updated for their open alerts. These do not reach sites built with docouture.